eclipse

解决:Could not resolve archetype org.apache.maven.archetypes:maven-archetype-quickstart

星期二, 四月 7th, 2015 | JAVA-and-J2EE | 没有评论

装了apache-maven-3.2.3-bin 并做好配置,在eclipse中新建maven工程时报错:

Could not resolve archetype org.apache.maven.archetypes:maven-archetype-quickstart:RELEASE from any of the configured repositories.
Could not resolve artifact
Missing org.apache.maven.archetypes:maven-archetype-quickstart:pom:RELEASE

解决办法:在本地库中装载maven-archetype-quickstart

1.从http://mirrors.ibiblio.org/pub/mirrors/maven2/org/apache/maven/archetypes/maven-archetype-quickstart/
或者国内的镜像
http://maven.oschina.net/content/groups/public/org/apache/maven/archetypes/maven-archetype-quickstart/
下载最新版maven-archetype-quickstart-1.1.jar

2.cmd窗口执行mvn install:install-file -DgroupId=org.apache.maven.archetypes -DartifactId=maven-archetype-quickstart -Dversion=1.1 -Dpackaging=jar -Dfile=maven-archetype-quickstart-1.1.jar

即可

Tags: ,

Eclipse之java was started but returned exit code 1报错并退出的解决方法

星期三, 四月 4th, 2012 | JAVA-and-J2EE | 2 Comments

今天正在用eclipse处理程序的时候突然报了个java was started but returned exit code 1,提示后就退出了,上网查询修改eclipse.ini即可.
本人环境为win7的64位系统,jdk为1.6.0_20:
解决之法:(安装目录eclipse.ini文件)
1.修改最大内存数-Xmx384m 为 -Xmx1024m (本人情况为因为最大内存过小)

2.按照1如果还不行,再配置
-vm
C:\Java\JDK\1.6\bin\javaw.exe
-vmargs
注意点:-vm 都分别各占一行,且此配置要在-vmargs上面

延伸阅读:eclipse.ini文件的说明(http://wiki.eclipse.org/Eclipse.ini)
异常图片截图记录:
› Continue reading

Tags: , ,

python开发环境搭建和与eclipse集成

星期五, 一月 20th, 2012 | pagemaker | 没有评论

Python与eclipse集成,分为三步:

1.下载Python的开发包,官方网站http://www.python.org下载并安装就可以了。
windows 下配置path路径,添加刚才的安装路径:D:\soft\worksoft\Python27
在cmd命令行中输入:python -V 其中V是大写的
输出:Python 2.7.2(输入你的安装版本即安装成功,超easy的说)

2.在eclipse里面,help->Install New Software在弹出的窗口中贴入如下地址:http://pydev.org/updates,点击add,然后ok,安装PyDev即可,安装完成后重启eclipse。

3.然后在eclipse里菜单windows->prefrence里找到PyDev->interpreter-Python在右上面点击New找到python.exe在Python的安装目录下面。

至此Python在eclipse的配置完成,就可以用eclipse新建项目进行eclipse开发了。

小记:关于python的学习资料可以去此网站看对应的教程很不错的http://woodpecker.org.cn/ Python教程

Tags: , , , ,

MyEclipse保存后不能自动编译 导致Tomcat发布报警告

星期五, 十二月 25th, 2009 | JAVA-and-J2EE | 没有评论

以前的工程好好的发布,今天发布的时候报了个警告,于是就把工程重建了下,竟发现不能编译了,吐血中ing,再查看WEB-INF/classes/,竟然里面是空的,而output路径也设的好好的啊,怪了,于是google了一下,发现有此问题的人还不少,其中有一位总结的比较详细,具体如下:

1. 确保 project->build automatically 已经被选上.

2. 如果选上了,也不好使, 使用这一招: project->clean..->选第2个clean select project, 勾上start build immediatelly

3.删除现在的项目,提前设置好编译文件输出路径,重新导入源文件,设置eclipse为保存时编译,然后在保存的时候就可以自动编译了

4.如果项目里引了某个不用的jar包,而那个包又被你删了,就会出现不报错但怎么也编译不出来class文件的情况,可以把所有包都删除,然后一个一个的再引入(需要的),不要一下子把所有包都引入来,没用的可能会引起不良后果.

5. 想删掉某个class文件重新生成,删除class文件后,但classes目录下的文件夹被其它程序打开,比如Total Commander。此时编译也不会通过,在problems下可能会提示“con”t delete classes ……”。关掉其它程序重新编译即可。

6.还有种情况是remove掉 JRE System Library,重新导入即可编译。但是什么原因导致的还不清楚。

7.把build path中所有包都remove掉。然后又add jars,add libraries把需要的加进去,居然又开始编译了。。。

8.project->properties->java build path->source->…/WEB-INF/src的output folder不要默认,编辑让它指向../WEB-INF/classes 然后重新点击build工程即可自动编译。

9.再就是最重要的要看工程下面是否缺少了work目录,由于CVS控制时不把work加如版本,所以checkout后没有这个目录,要手工加上有的工程就能自动编译了

PS:我的问题就是一个同事加了本地的jar包进去导致的不能编译输出,在project下的lib下看到jar包在他的路径下,哎,耽误那么长功夫查找,不过遇见问题就要解决问题才是正道,呵呵

Tags: , , , ,

myeclipse 6.5 代码提示(alt+/)不提示的修正解决办法

星期五, 二月 13th, 2009 | JAVA-and-J2EE | 一条评论

自己一直用的myeclipse升级到6.5时候,发现以前常习惯用的Alt+/的代码快速提示不能使用,但是自己输入后的再用Alt+/就可以了,不得已看了快捷键设置,发现被重新设置了,用着不习惯,改过来它;

myeclipse 6把alt+/分配给了单词提示,还有代码提示的快捷代码也不是alt+/,因此要恢复代码提示用alt+/.需要做两件事.
1,windows–>preference–>general–>keys 下设置Content Assist 的快捷键
2,windows–>preference–>general–>keys 下设置word completion 的快捷键 改成其它的.

如果还是不提示有可能是提示功能被关了.
如下做
1、菜单window->Preferences->Java->Editor->Content Assist->Enable auto activation 选项要打上勾
2、window->Preferences->Java->Editor->Content Assist->Advanced 上面的选项卡Select

the proposal kinds contained in the ‘default’ content assist list: 中把 Other Java

Proposals 选项打上勾就可以了。

Tags: ,

Installing PHPEclipse–php IDE eclipse plugin

星期一, 二月 9th, 2009 | JAVA-and-J2EE, php | 没有评论

       今天给论坛升级,要发现自己忘记了Ucenter的密码了;又要md5加密密码了,赶紧找php的编辑文件好处理,发现电脑重装后,只把myeclipse升级到6.5,对应的插件都没有了,继续安装吧;明天还要继续安装php的环境,真是烦啊,倒谈不上难了,废话不多说了,开始安装这个插件吧;

The simplest way to install PHPEclipse is to use the PHPEclipse update site.
If you are using Eclipse 3.2 you will want to use the following URL for your update site:
http://update.phpeclipse.com/update/stable/1.1.x
For Eclipse 3.3 and 3.4 use
http://update.phpeclipse.com/update/stable/1.2.x

俺的是3.3的就用这个了

Then select Search for new features to install -> Next
You will create a new remote site Name: PHPEclipse 1.2.x
The url is http://update.phpeclipse.com/update/stable/1.2.x then click Ok

Make sure PHPEclipse 1.2.x is check then click Finish
After it is installed you will need to activate the Perspective
To do that got to Window-> Open Perspective ->Other -> Select PHP -> Ok

官方有个对应的图文可以参考:Installing PHPEclipse

 

Tags: , ,

Rss

Search

文章分类

Meta